<!doctype html>
<!--[if lt IE 7]> <html class="no-js lt-ie9 lt-ie8 lt-ie7" lang="en-US"> <![endif]-->
<!--[if IE 7]>    <html class="no-js lt-ie9 lt-ie8" lang="en-US"> <![endif]-->
<!--[if IE 8]>    <html class="no-js lt-ie9" lang="en-US"> <![endif]-->
<!--[if IE 9]>    <html class="no-js lt-ie10" lang="en-US"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js" lang="en-US"> <!--<![endif]-->
<head>
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    <meta name='viewport' content='width=device-width, initial-scale=1, user-scalable=yes' />
    <link rel="profile" href="http://gmpg.org/xfn/11" />
    <link rel="pingback" href="https://guyanacaribbeanpolitics.news/xmlrpc.php" />
    <title>WPA welcomes steps to honour Dr. Walter Rodney but raps PNCR, PPP &#8211; Guyana Caribbean Politics</title>
<meta name='robots' content='max-image-preview:large' />
<meta property="og:type" content="article">
<meta property="og:title" content="WPA welcomes steps to honour Dr. Walter Rodney but raps PNCR, PPP">
<meta property="og:site_name" content="Guyana Caribbean Politics">
<meta property="og:description" content="WPA welcomes steps to honour Dr. Walter Rodney but raps PNCR, PPP Posted by: Denis Chabrol in News, Politics Friday, 11 June 2021, 22:09 0 Comments">
<meta property="og:url" content="https://guyanacaribbeanpolitics.news/2021/06/wpa-welcomes-steps-to-honour-dr-walter-rodney-but-raps-pncr-ppp/">
<meta property="og:locale" content="en_US">
<meta property="og:image" content="https://guyanacaribbeanpolitics.news/wp-content/uploads/2021/06/rodney.jpg">
<meta property="og:image:height" content="177">
<meta property="og:image:width" content="284">
<meta property="article:published_time" content="2021-06-12T09:33:46+00:00">
<meta property="article:modified_time" content="2021-06-12T09:33:46+00:00">
<meta property="article:author" content="https://guyanacaribbeanpolitics.news">
<meta property="article:section" content="Features">
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:title" content="WPA welcomes steps to honour Dr. Walter Rodney but raps PNCR, PPP">
<meta name="twitter:description" content="WPA welcomes steps to honour Dr. Walter Rodney but raps PNCR, PPP Posted by: Denis Chabrol in News, Politics Friday, 11 June 2021, 22:09 0 Comments">
<meta name="twitter:url" content="https://guyanacaribbeanpolitics.news/2021/06/wpa-welcomes-steps-to-honour-dr-walter-rodney-but-raps-pncr-ppp/">
<meta name="twitter:site" content="https://guyanacaribbeanpolitics.news">
<meta name="twitter:image:src" content="https://guyanacaribbeanpolitics.news/wp-content/uploads/2021/06/rodney.jpg">
<meta name="twitter:image:width" content="284">
<meta name="twitter:image:height" content="177">
			<script type="text/javascript">
              var jnews_ajax_url = '/?ajax-request=jnews'
			</script>
			<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Guyana Caribbean Politics &raquo; Feed" href="https://guyanacaribbeanpolitics.news/feed/" />
<link rel="alternate" type="application/rss+xml" title="Guyana Caribbean Politics &raquo; Comments Feed" href="https://guyanacaribbeanpolitics.news/comments/feed/" />
		<!-- This site uses the Google Analytics by ExactMetrics plugin v6.7.0 - Using Analytics tracking - https://www.exactmetrics.com/ -->
							<script src="//www.googletagmanager.com/gtag/js?id=UA-185401131-1"  type="text/javascript" data-cfasync="false"></script>
			<script type="text/javascript" data-cfasync="false">
				var em_version = '6.7.0';
				var em_track_user = true;
				var em_no_track_reason = '';
				
								var disableStr = 'ga-disable-UA-185401131-1';

				/* Function to detect opted out users */
				function __gtagTrackerIsOptedOut() {
					return document.cookie.indexOf( disableStr + '=true' ) > - 1;
				}

				/* Disable tracking if the opt-out cookie exists. */
				if ( __gtagTrackerIsOptedOut() ) {
					window[disableStr] = true;
				}

				/* Opt-out function */
				function __gtagTrackerOptout() {
					document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
					window[disableStr] = true;
				}

				if ( 'undefined' === typeof gaOptout ) {
					function gaOptout() {
						__gtagTrackerOptout();
					}
				}
								window.dataLayer = window.dataLayer || [];
				if ( em_track_user ) {
					function __gtagTracker() {dataLayer.push( arguments );}
					__gtagTracker( 'js', new Date() );
					__gtagTracker( 'set', {
						'developer_id.dNDMyYj' : true,
						                    });
					__gtagTracker( 'config', 'UA-185401131-1', {
						forceSSL:true,link_attribution:true,					} );
										window.gtag = __gtagTracker;										(
						function () {
							/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
							/* ga and __gaTracker compatibility shim. */
							var noopfn = function () {
								return null;
							};
							var newtracker = function () {
								return new Tracker();
							};
							var Tracker = function () {
								return null;
							};
							var p = Tracker.prototype;
							p.get = noopfn;
							p.set = noopfn;
							p.send = function (){
								var args = Array.prototype.slice.call(arguments);
								args.unshift( 'send' );
								__gaTracker.apply(null, args);
							};
							var __gaTracker = function () {
								var len = arguments.length;
								if ( len === 0 ) {
									return;
								}
								var f = arguments[len - 1];
								if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
									if ( 'send' === arguments[0] ) {
										var hitConverted, hitObject = false, action;
										if ( 'event' === arguments[1] ) {
											if ( 'undefined' !== typeof arguments[3] ) {
												hitObject = {
													'eventAction': arguments[3],
													'eventCategory': arguments[2],
													'eventLabel': arguments[4],
													'value': arguments[5] ? arguments[5] : 1,
												}
											}
										}
										if ( typeof arguments[2] === 'object' ) {
											hitObject = arguments[2];
										}
										if ( typeof arguments[5] === 'object' ) {
											Object.assign( hitObject, arguments[5] );
										}
										if ( 'undefined' !== typeof (
											arguments[1].hitType
										) ) {
											hitObject = arguments[1];
										}
										if ( hitObject ) {
											action = 'timing' === arguments[1].hitType ? 'timing_complete' : hitObject.eventAction;
											hitConverted = mapArgs( hitObject );
											__gtagTracker( 'event', action, hitConverted );
										}
									}
									return;
								}

								function mapArgs( args ) {
									var gaKey, hit = {};
									var gaMap = {
										'eventCategory': 'event_category',
										'eventAction': 'event_action',
										'eventLabel': 'event_label',
										'eventValue': 'event_value',
										'nonInteraction': 'non_interaction',
										'timingCategory': 'event_category',
										'timingVar': 'name',
										'timingValue': 'value',
										'timingLabel': 'event_label',
									};
									for ( gaKey in gaMap ) {
										if ( 'undefined' !== typeof args[gaKey] ) {
											hit[gaMap[gaKey]] = args[gaKey];
										}
									}
									return hit;
								}

								try {
									f.hitCallback();
								} catch ( ex ) {
								}
							};
							__gaTracker.create = newtracker;
							__gaTracker.getByName = newtracker;
							__gaTracker.getAll = function () {
								return [];
							};
							__gaTracker.remove = noopfn;
							__gaTracker.loaded = true;
							window['__gaTracker'] = __gaTracker;
						}
					)();
									} else {
										console.log( "" );
					( function () {
							function __gtagTracker() {
								return null;
							}
							window['__gtagTracker'] = __gtagTracker;
							window['gtag'] = __gtagTracker;
					} )();
									}
			</script>
				<!-- / Google Analytics by ExactMetrics -->
				<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/guyanacaribbeanpolitics.news\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://guyanacaribbeanpolitics.news/wp-includes/css/dist/block-library/style.min.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='wc-block-vendors-style-css'  href='https://guyanacaribbeanpolitics.news/wp-content/plugins/woocommerce/packages/woocommerce-blocks/build/vendors-style.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='wc-block-style-css'  href='https://guyanacaribbeanpolitics.news/wp-content/plugins/woocommerce/packages/woocommerce-blocks/build/style.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='woocommerce-layout-css'  href='https://guyanacaribbeanpolitics.news/wp-content/plugins/woocommerce/assets/css/woocommerce-layout.css?ver=5.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='woocommerce-smallscreen-css'  href='https://guyanacaribbeanpolitics.news/wp-content/plugins/woocommerce/assets/css/woocommerce-smallscreen.css?ver=5.2.2' type='text/css' media='only screen and (max-width: 768px)' />
<link rel='stylesheet' id='woocommerce-general-css'  href='https://guyanacaribbeanpolitics.news/wp-content/plugins/woocommerce/assets/css/woocommerce.css?ver=5.2.2' type='text/css' media='all' />
<style id='woocommerce-inline-inline-css' type='text/css'>
.woocommerce form .form-row .required { visibility: visible; }
</style>
<link rel='stylesheet' id='jeg_customizer_font-css'  href='//fonts.googleapis.com/css?family=Open+Sans%3Aregular%2C600%2C700%7CRoboto+Slab%3A300%2Cregular%2C700%7CSource+Sans+Pro%3Aregular%2C600%2C700&#038;display=swap&#038;ver=1.2.5' type='text/css' media='all' />
<link rel='stylesheet' id='mediaelement-css'  href='https://guyanacaribbeanpolitics.news/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://guyanacaribbeanpolitics.news/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-frontend-css'  href='https://guyanacaribbeanpolitics.news/wp-content/themes/GCP/assets/dist/frontend.min.css?ver=7.1.7' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-elementor-css'  href='https://guyanacaribbeanpolitics.news/wp-content/themes/GCP/assets/css/elementor-frontend.css?ver=7.1.7' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-style-css'  href='https://guyanacaribbeanpolitics.news/wp-content/themes/GCP/style.css?ver=7.1.7' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-darkmode-css'  href='https://guyanacaribbeanpolitics.news/wp-content/themes/GCP/assets/css/darkmode.css?ver=7.1.7' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-scheme-css'  href='https://guyanacaribbeanpolitics.news/wp-content/themes/GCP/data/import/sport/scheme.css?ver=7.1.7' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-paywall-css'  href='https://guyanacaribbeanpolitics.news/wp-content/plugins/jnews-paywall/assets/css/jpw-frontend.css?ver=7.0.9' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-social-login-style-css'  href='https://guyanacaribbeanpolitics.news/wp-content/plugins/jnews-social-login/assets/css/plugin.css?ver=7.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-select-share-css'  href='https://guyanacaribbeanpolitics.news/wp-content/plugins/jnews-social-share/assets/css/plugin.css' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-weather-style-css'  href='https://guyanacaribbeanpolitics.news/wp-content/plugins/jnews-weather/assets/css/plugin.css?ver=7.0.5' type='text/css' media='all' />
<script type='text/javascript' id='exactmetrics-frontend-script-js-extra'>
/* <![CDATA[ */
var exactmetrics_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/guyanacaribbeanpolitics.news","hash_tracking":"false","ua":"UA-185401131-1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://guyanacaribbeanpolitics.news/wp-content/plugins/google-analytics-dashboard-for-wp/assets/js/frontend-gtag.min.js?ver=6.7.0' id='exactmetrics-frontend-script-js'></script>
<script type='text/javascript' src='https://guyanacaribbeanpolitics.news/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://guyanacaribbeanpolitics.news/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<link rel="https://api.w.org/" href="https://guyanacaribbeanpolitics.news/wp-json/" /><link rel="alternate" type="application/json" href="https://guyanacaribbeanpolitics.news/wp-json/wp/v2/posts/1448" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://guyanacaribbeanpolitics.news/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://guyanacaribbeanpolitics.news/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.7.2" />
<meta name="generator" content="WooCommerce 5.2.2" />
<link rel="canonical" href="https://guyanacaribbeanpolitics.news/2021/06/wpa-welcomes-steps-to-honour-dr-walter-rodney-but-raps-pncr-ppp/" />
<link rel='shortlink' href='https://guyanacaribbeanpolitics.news/?p=1448' />
<link rel="alternate" type="application/json+oembed" href="https://guyanacaribbeanpolitics.news/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fguyanacaribbeanpolitics.news%2F2021%2F06%2Fwpa-welcomes-steps-to-honour-dr-walter-rodney-but-raps-pncr-ppp%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://guyanacaribbeanpolitics.news/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fguyanacaribbeanpolitics.news%2F2021%2F06%2Fwpa-welcomes-steps-to-honour-dr-walter-rodney-but-raps-pncr-ppp%2F&#038;format=xml" />
	<noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript>
	<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","@id":"https:\/\/guyanacaribbeanpolitics.news\/#organization","url":"https:\/\/guyanacaribbeanpolitics.news\/","name":"","logo":{"@type":"ImageObject","url":""},"sameAs":["#","#","#"]}</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"https:\/\/guyanacaribbeanpolitics.news\/#website","url":"https:\/\/guyanacaribbeanpolitics.news\/","name":"","potentialAction":{"@type":"SearchAction","target":"https:\/\/guyanacaribbeanpolitics.news\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<link rel="icon" href="https://guyanacaribbeanpolitics.news/wp-content/uploads/2020/11/guyana-e1446789600993-1-75x75.png" sizes="32x32" />
<link rel="icon" href="https://guyanacaribbeanpolitics.news/wp-content/uploads/2020/11/guyana-e1446789600993-1.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://guyanacaribbeanpolitics.news/wp-content/uploads/2020/11/guyana-e1446789600993-1.png" />
<meta name="msapplication-TileImage" content="https://guyanacaribbeanpolitics.news/wp-content/uploads/2020/11/guyana-e1446789600993-1.png" />
<style id="jeg_dynamic_css" type="text/css" data-type="jeg_custom-css">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</style><style type="text/css">
					.no_thumbnail .jeg_thumb,
					.thumbnail-container.no_thumbnail {
					    display: none !important;
					}
					.jeg_search_result .jeg_pl_xs_3.no_thumbnail .jeg_postblock_content,
					.jeg_sidefeed .jeg_pl_xs_3.no_thumbnail .jeg_postblock_content,
					.jeg_pl_sm.no_thumbnail .jeg_postblock_content {
					    margin-left: 0;
					}
					.jeg_postblock_11 .no_thumbnail .jeg_postblock_content,
					.jeg_postblock_12 .no_thumbnail .jeg_postblock_content,
					.jeg_postblock_12.jeg_col_3o3 .no_thumbnail .jeg_postblock_content  {
					    margin-top: 0;
					}
					.jeg_postblock_15 .jeg_pl_md_box.no_thumbnail .jeg_postblock_content,
					.jeg_postblock_19 .jeg_pl_md_box.no_thumbnail .jeg_postblock_content,
					.jeg_postblock_24 .jeg_pl_md_box.no_thumbnail .jeg_postblock_content,
					.jeg_sidefeed .jeg_pl_md_box .jeg_postblock_content {
					    position: relative;
					}
					.jeg_postblock_carousel_2 .no_thumbnail .jeg_post_title a,
					.jeg_postblock_carousel_2 .no_thumbnail .jeg_post_title a:hover,
					.jeg_postblock_carousel_2 .no_thumbnail .jeg_post_meta .fa {
					    color: #212121 !important;
					} 
				</style>		<style type="text/css" id="wp-custom-css">
			.grecaptcha-badge { 
    visibility: hidden;
}		</style>
		<style id="yellow-pencil">
/*
	The following CSS codes are created by the YellowPencil plugin.
	https://yellowpencil.waspthemes.com/
*/
.jeg_midbar a img{-webkit-box-sizing:border-box !important;box-sizing:border-box !important;max-width:96% !important;position:relative;top:0px;left:0px;}.jeg_video_playlist_wrapper .jeg_video_playlist_list_wrapper .jeg_video_playlist_current{background-color:#31942e;}.jeg_video_playlist_play .jeg_video_playlist_play_icon i{background-color:rgba(0,0,0,0);color:#020202;}.jeg_video_playlist_current .jeg_video_playlist_play span{font-size:11px !important;letter-spacing:1.6px;}
</style></head>
<body class="post-template-default single single-post postid-1448 single-format-standard wp-embed-responsive theme-GCP non-logged-in woocommerce-no-js jeg_toggle_dark jeg_single_tpl_2 jnews jeg_boxed jsc_normal elementor-default elementor-kit-5">

    
    
    <div class="jeg_ad jeg_ad_top jnews_header_top_ads">
        <div class='ads-wrapper  '></div>    </div>

    <!-- The Main Wrapper
    ============================================= -->
    <div class="jeg_viewport">

        
        <div class="jeg_header_wrapper">
            <div class="jeg_header_instagram_wrapper">
    </div>

<!-- HEADER -->
<div class="jeg_header full">
    <div class="jeg_topbar jeg_container dark">
    <div class="container">
        <div class="jeg_nav_row">
            
                <div class="jeg_nav_col jeg_nav_left  jeg_nav_grow">
                    <div class="item_wrap jeg_nav_alignleft">
                        <div class="jeg_nav_item">
	<ul class="jeg_menu jeg_top_menu"><li id="menu-item-956" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-956"><a href="https://guyanacaribbeanpolitics.news/my-account/">My account</a></li>
<li id="menu-item-957" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-957"><a href="https://guyanacaribbeanpolitics.news/cart/">My Cart</a></li>
<li id="menu-item-958" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-958"><a href="https://guyanacaribbeanpolitics.news/checkout/">Checkout</a></li>
</ul></div>                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_center  jeg_nav_normal">
                    <div class="item_wrap jeg_nav_aligncenter">
                                            </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_right  jeg_nav_grow">
                    <div class="item_wrap jeg_nav_alignright">
                        <div class="jeg_nav_item jeg_top_date">
    Saturday, June 12, 2021</div><div class="jeg_nav_item jnews_header_topbar_weather">
    </div><div class="jeg_nav_item jeg_nav_account">
    <ul class="jeg_accountlink jeg_menu">
        <li><a href="#jeg_loginform" class="jeg_popuplink"><i class="fa fa-lock"></i> Login</a></li><li><a href="#jeg_registerform" class="jeg_popuplink"><i class="fa fa-user"></i> Register</a></li>    </ul>
</div>                    </div>
                </div>

                        </div>
    </div>
</div><!-- /.jeg_container --><div class="jeg_midbar jeg_container normal">
    <div class="container">
        <div class="jeg_nav_row">
            
                <div class="jeg_nav_col jeg_nav_left jeg_nav_grow">
                    <div class="item_wrap jeg_nav_alignleft">
                        <div class="jeg_nav_item jeg_logo jeg_desktop_logo">
			<div class="site-title">
	    	<a href="https://guyanacaribbeanpolitics.news/" style="padding: 0 0 0 0;">
	    	    <img class='jeg_logo_img' src="https://guyanacaribbeanpolitics.news/wp-content/uploads/2020/11/guyana.png"  alt="Guyana Caribbean Politics"data-light-src="https://guyanacaribbeanpolitics.news/wp-content/uploads/2020/11/guyana.png" data-light-srcset="https://guyanacaribbeanpolitics.news/wp-content/uploads/2020/11/guyana.png 1x,  2x" data-dark-src="" data-dark-srcset=" 1x,  2x">	    	</a>
	    </div>
	</div><div class="jeg_main_menu_wrapper">
<div class="jeg_nav_item jeg_mainmenu_wrap"><ul class="jeg_menu jeg_main_menu jeg_menu_style_2" data-animation="animate"><li id="menu-item-371" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-371 bgnav" data-item-row="default" ><a href="https://guyanacaribbeanpolitics.news">Home</a></li>
<li id="menu-item-374" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-374 bgnav" data-item-row="default" ><a href="https://guyanacaribbeanpolitics.news/category/features/">Features</a></li>
<li id="menu-item-375" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-375 bgnav" data-item-row="default" ><a href="#">Columns</a>
<ul class="sub-menu">
	<li id="menu-item-376" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-376 bgnav" data-item-row="default" ><a href="https://guyanacaribbeanpolitics.news/category/open-word/">Open Word</a></li>
	<li id="menu-item-377" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-377 bgnav" data-item-row="default" ><a href="https://guyanacaribbeanpolitics.news/category/hindssight/">Hinds’Sight</a></li>
	<li id="menu-item-378" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-378 bgnav" data-item-row="default" ><a href="https://guyanacaribbeanpolitics.news/category/media-comments/">Media Comments</a></li>
	<li id="menu-item-379" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-379 bgnav" data-item-row="default" ><a href="https://guyanacaribbeanpolitics.news/category/other-opinions/">Other Opinions</a></li>
</ul>
</li>
<li id="menu-item-380" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-380 bgnav" data-item-row="default" ><a href="#">Videos</a>
<ul class="sub-menu">
	<li id="menu-item-384" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-384 bgnav" data-item-row="default" ><a href="https://guyanacaribbeanpolitics.news/category/guyana-politics-podcast/">Guyana Politics Podcast</a></li>
	<li id="menu-item-385" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-385 bgnav" data-item-row="default" ><a href="https://guyanacaribbeanpolitics.news/category/david-hinds-speaks/">David Hinds Speaks</a></li>
	<li id="menu-item-1223" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1223 bgnav" data-item-row="default" ><a href="https://guyanacaribbeanpolitics.news/category/videos/">Politics 101 with Dr. David Hinds</a></li>
</ul>
</li>
<li id="menu-item-839" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-839 bgnav" data-item-row="default" ><a href="https://guyanacaribbeanpolitics.news/bookstore/">BOOKSTORE</a></li>
<li id="menu-item-383" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-383 bgnav" data-item-row="default" ><a href="#">Academic Courses</a>
<ul class="sub-menu">
	<li id="menu-item-386" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-386 bgnav" data-item-row="default" ><a href="https://guyanacaribbeanpolitics.news/category/guyana-political-history/">Guyana Political History</a></li>
</ul>
</li>
<li id="menu-item-382" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-382 bgnav" data-item-row="default" ><a href="#">Publications</a>
<ul class="sub-menu">
	<li id="menu-item-389" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-389 bgnav" data-item-row="default" ><a href="#">Books</a></li>
	<li id="menu-item-390" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-390 bgnav" data-item-row="default" ><a href="#">Articles</a></li>
</ul>
</li>
<li id="menu-item-794" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-794 bgnav" data-item-row="default" ><a href="#">Organizations</a>
<ul class="sub-menu">
	<li id="menu-item-795" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-795 bgnav" data-item-row="default" ><a href="https://guyanacaribbeanpolitics.news/category/wpa/">WPA</a></li>
	<li id="menu-item-863" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-863 bgnav" data-item-row="default" ><a href="https://guyanacaribbeanpolitics.news/category/sage/">SAGE</a></li>
</ul>
</li>
</ul></div></div>
                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_center jeg_nav_normal">
                    <div class="item_wrap jeg_nav_aligncenter">
                                            </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignright">
                        <!-- Search Icon -->
<div class="jeg_nav_item jeg_search_wrapper search_icon jeg_search_popup_expand">
    <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
    <form action="https://guyanacaribbeanpolitics.news/" method="get" class="jeg_search_form" target="_top">
    <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
    <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>
<!-- jeg_search_hide with_result no_result -->
<div class="jeg_search_result jeg_search_hide with_result">
    <div class="search-result-wrapper">
    </div>
    <div class="search-link search-noresult">
        No Result    </div>
    <div class="search-link search-all-button">
        <i class="fa fa-search"></i> View All Result    </div>
</div></div>                    </div>
                </div>

                        </div>
    </div>
</div></div><!-- /.jeg_header -->        </div>

        <div class="jeg_header_sticky">
            <div class="sticky_blankspace"></div>
<div class="jeg_header full">
    <div class="jeg_container">
        <div data-mode="scroll" class="jeg_stickybar jeg_navbar jeg_navbar_wrapper jeg_navbar_normal jeg_navbar_fitwidth jeg_navbar_normal">
            <div class="container">
    <div class="jeg_nav_row">
        
            <div class="jeg_nav_col jeg_nav_left jeg_nav_grow">
                <div class="item_wrap jeg_nav_alignleft">
                    <div class="jeg_main_menu_wrapper">
<div class="jeg_nav_item jeg_mainmenu_wrap"><ul class="jeg_menu jeg_main_menu jeg_menu_style_2" data-animation="animate"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-371 bgnav" data-item-row="default" ><a href="https://guyanacaribbeanpolitics.news">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-374 bgnav" data-item-row="default" ><a href="https://guyanacaribbeanpolitics.news/category/features/">Features</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-375 bgnav" data-item-row="default" ><a href="#">Columns</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-376 bgnav" data-item-row="default" ><a href="https://guyanacaribbeanpolitics.news/category/open-word/">Open Word</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-377 bgnav" data-item-row="default" ><a href="https://guyanacaribbeanpolitics.news/category/hindssight/">Hinds’Sight</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-378 bgnav" data-item-row="default" ><a href="https://guyanacaribbeanpolitics.news/category/media-comments/">Media Comments</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-379 bgnav" data-item-row="default" ><a href="https://guyanacaribbeanpolitics.news/category/other-opinions/">Other Opinions</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-380 bgnav" data-item-row="default" ><a href="#">Videos</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-384 bgnav" data-item-row="default" ><a href="https://guyanacaribbeanpolitics.news/category/guyana-politics-podcast/">Guyana Politics Podcast</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-385 bgnav" data-item-row="default" ><a href="https://guyanacaribbeanpolitics.news/category/david-hinds-speaks/">David Hinds Speaks</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1223 bgnav" data-item-row="default" ><a href="https://guyanacaribbeanpolitics.news/category/videos/">Politics 101 with Dr. David Hinds</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-839 bgnav" data-item-row="default" ><a href="https://guyanacaribbeanpolitics.news/bookstore/">BOOKSTORE</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-383 bgnav" data-item-row="default" ><a href="#">Academic Courses</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-386 bgnav" data-item-row="default" ><a href="https://guyanacaribbeanpolitics.news/category/guyana-political-history/">Guyana Political History</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-382 bgnav" data-item-row="default" ><a href="#">Publications</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-389 bgnav" data-item-row="default" ><a href="#">Books</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-390 bgnav" data-item-row="default" ><a href="#">Articles</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-794 bgnav" data-item-row="default" ><a href="#">Organizations</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-795 bgnav" data-item-row="default" ><a href="https://guyanacaribbeanpolitics.news/category/wpa/">WPA</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-863 bgnav" data-item-row="default" ><a href="https://guyanacaribbeanpolitics.news/category/sage/">SAGE</a></li>
</ul>
</li>
</ul></div></div>
                </div>
            </div>

            
            <div class="jeg_nav_col jeg_nav_center jeg_nav_normal">
                <div class="item_wrap jeg_nav_aligncenter">
                                    </div>
            </div>

            
            <div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
                <div class="item_wrap jeg_nav_alignright">
                    <!-- Search Icon -->
<div class="jeg_nav_item jeg_search_wrapper search_icon jeg_search_popup_expand">
    <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
    <form action="https://guyanacaribbeanpolitics.news/" method="get" class="jeg_search_form" target="_top">
    <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
    <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>
<!-- jeg_search_hide with_result no_result -->
<div class="jeg_search_result jeg_search_hide with_result">
    <div class="search-result-wrapper">
    </div>
    <div class="search-link search-noresult">
        No Result    </div>
    <div class="search-link search-all-button">
        <i class="fa fa-search"></i> View All Result    </div>
</div></div>                </div>
            </div>

                </div>
</div>        </div>
    </div>
</div>
        </div>

        <div class="jeg_navbar_mobile_wrapper">
            <div class="jeg_navbar_mobile" data-mode="scroll">
    <div class="jeg_mobile_bottombar jeg_mobile_midbar jeg_container dark">
    <div class="container">
        <div class="jeg_nav_row">
            
                <div class="jeg_nav_col jeg_nav_left jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignleft">
                        <div class="jeg_nav_item">
    <a href="#" class="toggle_btn jeg_mobile_toggle"><i class="fa fa-bars"></i></a>
</div>                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_center jeg_nav_grow">
                    <div class="item_wrap jeg_nav_aligncenter">
                        <div class="jeg_nav_item jeg_mobile_logo">
			<div class="site-title">
	    	<a href="https://guyanacaribbeanpolitics.news/">
		        <img class='jeg_logo_img' src="https://guyanacaribbeanpolitics.news/wp-content/uploads/2020/11/gcp__110x110.png" srcset="https://guyanacaribbeanpolitics.news/wp-content/uploads/2020/11/gcp__110x110.png 1x, https://guyanacaribbeanpolitics.news/wp-content/uploads/2020/11/gcp__110x110.png 2x" alt="Guyana Caribbean Politics"data-light-src="https://guyanacaribbeanpolitics.news/wp-content/uploads/2020/11/gcp__110x110.png" data-light-srcset="https://guyanacaribbeanpolitics.news/wp-content/uploads/2020/11/gcp__110x110.png 1x, https://guyanacaribbeanpolitics.news/wp-content/uploads/2020/11/gcp__110x110.png 2x" data-dark-src="https://guyanacaribbeanpolitics.news/wp-content/themes/GCP/assets/img/logo_darkmode.png" data-dark-srcset="https://guyanacaribbeanpolitics.news/wp-content/themes/GCP/assets/img/logo_darkmode.png 1x, https://guyanacaribbeanpolitics.news/wp-content/themes/GCP/assets/img/logo_darkmode@2x.png 2x">		    </a>
	    </div>
	</div>                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignright">
                        <div class="jeg_nav_item jeg_search_wrapper jeg_search_popup_expand">
    <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
	<form action="https://guyanacaribbeanpolitics.news/" method="get" class="jeg_search_form" target="_top">
    <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
    <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>
<!-- jeg_search_hide with_result no_result -->
<div class="jeg_search_result jeg_search_hide with_result">
    <div class="search-result-wrapper">
    </div>
    <div class="search-link search-noresult">
        No Result    </div>
    <div class="search-link search-all-button">
        <i class="fa fa-search"></i> View All Result    </div>
</div></div>                    </div>
                </div>

                        </div>
    </div>
</div></div>
<div class="sticky_blankspace" style="height: 60px;"></div>        </div>    <div class="post-wrapper">

        <div class="post-wrap" >

            
            <div class="jeg_main ">
                <div class="jeg_container">
                    <div class="jeg_content jeg_singlepage">
    <div class="container">

        <div class="jeg_ad jeg_article_top jnews_article_top_ads">
            <div class='ads-wrapper  '></div>        </div>

        
                        <div class="jeg_breadcrumbs jeg_breadcrumb_container">
                <div id="breadcrumbs"><span class="">
                <a href="https://guyanacaribbeanpolitics.news">Home</a>
            </span><i class="fa fa-angle-right"></i><span class="breadcrumb_last_link">
                <a href="https://guyanacaribbeanpolitics.news/category/features/">Features</a>
            </span></div>            </div>
            
            <div class="entry-header">
	            
                <h1 class="jeg_post_title">WPA welcomes steps to honour Dr. Walter Rodney but raps PNCR, PPP</h1>

                
                <div class="jeg_meta_container"><div class="jeg_post_meta jeg_post_meta_2">

						<div class="jeg_meta_author">
				<img alt='admin' src='https://secure.gravatar.com/avatar/dd9d9c69631819921b14bec979e0b0de?s=80&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/dd9d9c69631819921b14bec979e0b0de?s=160&#038;d=mm&#038;r=g 2x' class='avatar avatar-80 photo' height='80' width='80' loading='lazy'/>				<span class="meta_text">by</span>
				<a href="https://guyanacaribbeanpolitics.news/author/dhinds_4dhn5itw/">admin</a>			</div>
			
			<div class="jeg_meta_date">
			<a href="https://guyanacaribbeanpolitics.news/2021/06/wpa-welcomes-steps-to-honour-dr-walter-rodney-but-raps-pncr-ppp/">June 12, 2021</a>
		</div>
	
			<div class="jeg_meta_category">
			<span><span class="meta_text">in</span>
				<a href="https://guyanacaribbeanpolitics.news/category/features/" rel="category tag">Features</a>			</span>
		</div>
	
	
	<div class="meta_right">
		<div class='jeg_meta_like_container jeg_meta_like'>
                
            </div>					<div class="jeg_meta_comment"><a href="https://guyanacaribbeanpolitics.news/2021/06/wpa-welcomes-steps-to-honour-dr-walter-rodney-but-raps-pncr-ppp/#comments"><i
						class="fa fa-comment-o"></i> 0</a></div>
			</div>
</div>
</div>
            </div>

            <div class="row">
                <div class="jeg_main_content col-md-8">

                    <div class="jeg_inner_content">
                        <div class="jeg_featured featured_image"><a href="https://guyanacaribbeanpolitics.news/wp-content/uploads/2021/06/rodney.jpg"><div class="thumbnail-container animate-lazy" style="padding-bottom:62.324%"><img width="284" height="177" src="https://guyanacaribbeanpolitics.news/wp-content/themes/GCP/assets/img/jeg-empty.png" class="attachment-jnews-750x536 size-jnews-750x536 lazyload wp-post-image" alt="WPA welcomes steps to honour Dr. Walter Rodney but raps PNCR, PPP" loading="lazy" data-src="https://guyanacaribbeanpolitics.news/wp-content/uploads/2021/06/rodney.jpg" data-srcset="" data-sizes="auto" data-expand="700" /></div></a></div>
                        <div class="jeg_share_top_container"></div>
                        <div class="jeg_ad jeg_article jnews_content_top_ads "><div class='ads-wrapper  '></div></div>
                        <div class="entry-content with-share">
                            <div class="jeg_share_button share-float jeg_sticky_share clearfix share-normal">
                                <div class="jeg_share_float_container"><div class="jeg_sharelist">
                <a href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fguyanacaribbeanpolitics.news%2F2021%2F06%2Fwpa-welcomes-steps-to-honour-dr-walter-rodney-but-raps-pncr-ppp%2F" rel='nofollow'  class="jeg_btn-facebook expanded"><i class="fa fa-facebook-official"></i><span>Share on Facebook</span></a><a href="https://twitter.com/intent/tweet?text=WPA+welcomes+steps+to+honour+Dr.+Walter+Rodney+but+raps+PNCR%2C+PPP&url=https%3A%2F%2Fguyanacaribbeanpolitics.news%2F2021%2F06%2Fwpa-welcomes-steps-to-honour-dr-walter-rodney-but-raps-pncr-ppp%2F" rel='nofollow'  class="jeg_btn-twitter expanded"><i class="fa fa-twitter"></i><span>Share on Twitter</span></a><a href="https://plus.google.com/share?url=https%3A%2F%2Fguyanacaribbeanpolitics.news%2F2021%2F06%2Fwpa-welcomes-steps-to-honour-dr-walter-rodney-but-raps-pncr-ppp%2F" rel='nofollow'  class="jeg_btn-google-plus removed "><i class="fa fa-google-plus"></i></a>
                <div class="share-secondary">
                    <a href="https://www.linkedin.com/shareArticle?url=https%3A%2F%2Fguyanacaribbeanpolitics.news%2F2021%2F06%2Fwpa-welcomes-steps-to-honour-dr-walter-rodney-but-raps-pncr-ppp%2F&title=WPA+welcomes+steps+to+honour+Dr.+Walter+Rodney+but+raps+PNCR%2C+PPP" rel='nofollow'  class="jeg_btn-linkedin "><i class="fa fa-linkedin"></i></a><a href="https://www.pinterest.com/pin/create/bookmarklet/?pinFave=1&url=https%3A%2F%2Fguyanacaribbeanpolitics.news%2F2021%2F06%2Fwpa-welcomes-steps-to-honour-dr-walter-rodney-but-raps-pncr-ppp%2F&media=https://guyanacaribbeanpolitics.news/wp-content/uploads/2021/06/rodney.jpg&description=WPA+welcomes+steps+to+honour+Dr.+Walter+Rodney+but+raps+PNCR%2C+PPP" rel='nofollow'  class="jeg_btn-pinterest "><i class="fa fa-pinterest"></i></a>
                </div>
                <a href="#" class="jeg_btn-toggle"><i class="fa fa-share"></i></a>
            </div></div>                            </div>

                            <div class="content-inner ">
                                <h1 class="name post-title entry-title">WPA welcomes steps to honour Dr. Walter Rodney but raps PNCR, PPP</h1>
<p class="post-meta"><span class="post-meta-author">Posted by: <a title="" href="https://demerarawaves.com/author/demwaves/">Denis Chabrol</a></span> <span class="post-cats">in <a href="https://demerarawaves.com/category/news/" rel="category tag">News</a>, <a href="https://demerarawaves.com/category/news/politics/" rel="category tag">Politics</a></span> <span class="tie-date">Friday, 11 June 2021, 22:09</span> <span class="post-comments"><a href="https://demerarawaves.com/2021/06/11/wpa-welcomes-steps-to-honour-dr-walter-rodney-but-raps-pncr-ppp/#disqus_thread" data-disqus-identifier="56863 https://demerarawaves.com/?p=56863">0 Comments</a></span></p>
<div class="clear"></div>
<div class="entry">
<p class="post-modified-info">Last Updated on Friday, 11 June 2021, 22:11 by <a class="last-modified-author" href="http://www.demerarawaves.com/" target="_blank" rel="noopener">Denis Chabrol</a></p>
<div id="attachment_15515" class="wp-caption alignleft"><img loading="lazy" class="size-full wp-image-15515" src="https://demerarawaves.com/wp-content/uploads/2016/02/walter_rodney.jpg" alt="" width="201" height="250" aria-describedby="caption-attachment-15515" /></p>
<p id="caption-attachment-15515" class="wp-caption-text">Dr. Walter Rodney</p>
</div>
<p>The Working People’s Alliance (WPA) on Friday welcomed the decision by the Guyana government to honor world-acclaimed historian and party co-leader Dr. Walter Rodney who was killed in a bomb-blast on June 13, 1980 at the height of a civil rebellion to dislodge the Forbes Burnham dictatorship from office.</p>
<p>“We are especially heartened that the death certificate of our beloved brother would be amended to reflect the true cause of his demise–assassination. WPA has never wavered in our belief that Dr. Rodney was murdered by agents and at the direction of the government of the day because of his political activism,” the WPA said in a statement.</p>
<div class="google-auto-placed ap_container"><ins class="adsbygoogle adsbygoogle-noablate" data-ad-format="auto" data-ad-client="ca-pub-8351474699761107" data-adsbygoogle-status="done" data-ad-status="filled"><ins id="aswift_2_expand" tabindex="0" title="Advertisement" aria-label="Advertisement"><ins id="aswift_2_anchor"></ins></ins></ins>Decades later in 2011, the WPA joined the People’s National Congress Reform (PNCR)-led A Partnership for National Unity (APNU) which, in alliance with the Alliance For Change (AFC), won the 2015 general and regional elections.</div>
<p>But sections of the PNCR had decades later still remained lukewarm towards the WPA and had even terminated the 2014 Commission of Inquiry into his death and had defeated a motion for the report to be published and the recommendations implemented. The WPA  condemned in the “strongest terms” the PNC’s leadership, past and present. The former presided over Rodney’s murder while the latter when given the opportunity to redeem itself chose to assassinate our brother a second time. That party’s abrupt termination of the Rodney Commission of Inquiry upon taking office, its  blunt refusal to implement reasonable  recommendations of the Commission and to formally release its report reflected a political viciousness that has no parallel in recent Caribbean political history. What is even more cynical is that they did so as a government in which Rodney’s party was a junior member. It was one of  the worst betrayals of political trust that exposed the WPA to unjustified but, in the circumstances, understandable ridicule and condemnation from those opposed to national reconciliation.”</p>
<p>Though the WPA walked away from APNU after the coalition’s defeat at the March 2020 general and regional elections, that small party has remained critical of the incumbent People’s Progressive Party Civic (PPPC) administration for the way  that it has been governing Guyana. The WPA and the PPP had been allies under the banner of the Patriotic Coalition for Democracy (PCD) whose aim had been to restore electoral democracy.</p>
<div class="google-auto-placed ap_container"></div>
<p>Despite its alliance with the PNCR, the WPA had always maintained that Dr. Rodney had been assassinated at the hands of the Burnham regime by a bomb-in-walkie-talkie that had been supplied by now late Guyana Defence Force electronics expert, Sergeant Gregory Smith.  The Commission of Inquiry had heard testimony that at the time of the incident, the WPA had been obtaining long-range communication systems.</p>
<div id="attachment_56864" class="wp-caption alignright"><img loading="lazy" class="size-medium wp-image-56864" src="https://demerarawaves.com/wp-content/uploads/2021/06/anil-nandlall-rodney-300x203.jpg" sizes="(max-width: 300px) 100vw, 300px" srcset="https://demerarawaves.com/wp-content/uploads/2021/06/anil-nandlall-rodney-300x203.jpg 300w, https://demerarawaves.com/wp-content/uploads/2021/06/anil-nandlall-rodney.jpg 419w" alt="" width="300" height="203" aria-describedby="caption-attachment-56864" /></p>
<p id="caption-attachment-56864" class="wp-caption-text">Attorney General Anil Nandlall delivering a statement on steps that have been taken to recognise Dr. Walter Rodney.</p>
</div>
<p>Attorney General Anil Nandlall’s announced that the 1988 inquest into Rodney’s death would be invalidated because it states that he died as a result of misadventure; his children’s books, Lakshmi Out of India and Kofi Baadu Out of Africa, would be made compulsory reading as part of the schools curriculum; the National Archives would be renamed; Rodney’s grave and memorial site would be managed by the National Trust and the documents concerning the Commission of Inquiry into his death would be digitised and stored in the archives at a United States university.</p>
<p>WPA says it now awaits the implementation of the initiatives by the government. “We are particularly interested in the intention to have Walter Rodney’s books become part of the national education curriculum. Rodney has earned this exalted place by virtue of the superlative quality of his scholarship and its inherent commitment to national wholeness.”  At the same time, the WPA cautioned the government against using Rodney as the cover to insert into the educational curriculum PPP’s partisan version of the country’s historical journey and reality.</p>
<p>Finally, WPA must remind that though the announcements emanate from the PPP, they are done in the name of every single Guyanese regardless of ethnicity or political affiliation. The resources that will be used to implement the decisions are the products of the labour of all Guyanese, including the political descendant of the assassins. In the end, Walter Rodney belongs to no single political party, ethnicity or race—by his activism and example he is the embodiment of the quintessential Guyanese.</p>
<p>The WPA, despite its short-lived relations with the PNCR, on Friday stuck to its historical position that Dr. Rodney had been assassinated. “WPA has never wavered in our belief that Dr. Rodney was murdered by agents and at the direction of the government of the day because of his political activism. It is an act that will forever be a stain on the face our independence and it will always be a grim reminder of the nasty underbelly of our native politics,” the party stated</p>
<p>The WPA credited the PPP administration’s decisions to the direct result of four decades of relentless advocacy and struggle  by many colleagues, friends and admirers of Dr. Rodney. “The WPA was in the forefront of this fight, but special recognition must be given to the Rodney family which never gave up the fight for justice for a husband, brother, father and relative. This is indeed a moment of overcoming for Guyana, the Caribbean and the wider world. It is also a moment of justice for other martyrs of that revolutionary moment such as Ohene Koama, Edward Dublin and Father Bernard Darke,” the party added.</p>
<p>Despite its deep differences with the PPP and its disdain for that party’s opportunism on the Walter Rodney issue over the years, WPA says its commends the party for taking the announced initiative. “Notwithstanding the fact that the PPP takes this initiative at a time when that party is engaged in the worst assault on national jointness in Guyana’s post-independence history, they  must be recognized for doing the right and hounarable thing. Sometimes in politics we must be able to extricate elements of  progressive outcomes from webs of conspiracies. In this instance WPA separates Rodney and the announced initiatives from the real and perceived sinister political intent of the authors,” the party added.</p>
<p>Consistent with this stance, WPA expressed its utter disgust with the way in which the PPP has used the memory of Walter Rodney to encourage the further divide of Guyana politically and ethno-racially. The WPA chastised the PPP for never missing  an opportunity  to mis-locate that Guyanese patriot outside of his African Guyanese heritage and place him and his life’s work in collision and conflict with the interests of that segment of our nation. It is a crime that is only slightly less grievous than his assassination.</p>
<p>According to the WPA, Rodney was a prophet of multiracialism, but he was forever proud of is African ancestry and had nothing but contempt for Black self-haters. “Guyanese should also be reminded that despite its recent outpourings, the PPP has always accepted the PNC’s version of Rodney’s death and the activities of the WPA at that time. That party’s characterization of Rodney and the WPA as “adventurists” who delivered Rodney’s head on a “platter” gave credence to the PNC’s narrative that Rodney’s murder by the State was justified.</p>
<p>Reflecting on its recent relations with the PNCR, the WPA said that party’s top leadership would be condemned f0rever.  The WPA defended its decision to remain in the coalition although the PNCR had shown disdain for honouring Dr. Rodney. “WPA showed good faith in the interest of national healing by joining a partnership with a party whose previous leadership had assassinated our leader but was rewarded with gross disrespect by a narrowminded leadership which could not recognize that healing a nation is always sacrosanct and necessary and must be  paramount to partisan considerations. History will forever harshly judge that leadership for its lack of foresight and vision when it was most needed. But it is not too late for the current transitional leadership of the PNC to find a way to extricate the party from those sordid chapters.”</p>
</div>
                                
	                            
                                                            </div>


                        </div>
	                    <div class="jeg_share_bottom_container"></div>
	                                            <div class="jeg_ad jeg_article jnews_content_bottom_ads "><div class='ads-wrapper  '></div></div><div class="jnews_prev_next_container"></div><div class="jnews_author_box_container ">
	<div class="jeg_authorbox">
		<div class="jeg_author_image">
			<img alt='admin' src='https://secure.gravatar.com/avatar/dd9d9c69631819921b14bec979e0b0de?s=80&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/dd9d9c69631819921b14bec979e0b0de?s=160&#038;d=mm&#038;r=g 2x' class='avatar avatar-80 photo' height='80' width='80' loading='lazy'/>		</div>
		<div class="jeg_author_content">
			<h3 class="jeg_author_name">
				<a href="https://guyanacaribbeanpolitics.news/author/dhinds_4dhn5itw/">
					admin				</a>
			</h3>
			<p class="jeg_author_desc">
							</p>

							<div class="jeg_author_socials">
												<a target='_blank' href='https://guyanacaribbeanpolitics.news' class='url'><i class='fa fa-globe'></i> </a>
											</div>
			
		</div>
	</div>
</div><div class="jnews_related_post_container"></div><div class="jnews_popup_post_container"></div><div class="jnews_comment_container"></div>                    </div>

                </div>
                
<div class="jeg_sidebar  jeg_sticky_sidebar col-md-4">
    <div class="widget widget_jnews_recent_news" id="jnews_recent_news-2">        <div class="jeg_postblock">
                            <div class="jeg_post jeg_pl_sm post-1448 post type-post status-publish format-standard has-post-thumbnail hentry category-features">
                    <div class="jeg_thumb">
                                                <a href="https://guyanacaribbeanpolitics.news/2021/06/wpa-welcomes-steps-to-honour-dr-walter-rodney-but-raps-pncr-ppp/">
                            <div class="thumbnail-container animate-lazy  size-715 "><img width="120" height="86" src="https://guyanacaribbeanpolitics.news/wp-content/themes/GCP/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="WPA welcomes steps to honour Dr. Walter Rodney but raps PNCR, PPP" loading="lazy" data-src="https://guyanacaribbeanpolitics.news/wp-content/uploads/2021/06/rodney-120x86.jpg" data-srcset="" data-sizes="auto" data-expand="700" /></div>                        </a>
                    </div>
                    <div class="jeg_postblock_content">
                        <h3 property="headline" class="jeg_post_title"><a property="url" href="https://guyanacaribbeanpolitics.news/2021/06/wpa-welcomes-steps-to-honour-dr-walter-rodney-but-raps-pncr-ppp/">WPA welcomes steps to honour Dr. Walter Rodney but raps PNCR, PPP</a></h3>
                                            <div class="jeg_post_meta">
                            <div property="datePublished" class="jeg_meta_date"><i class="fa fa-clock-o"></i> June 12, 2021</div>
                        </div>
                                        </div>
                </div>
                                <div class="jeg_post jeg_pl_sm post-1445 post type-post status-publish format-standard has-post-thumbnail hentry category-features">
                    <div class="jeg_thumb">
                                                <a href="https://guyanacaribbeanpolitics.news/2021/06/former-wpa-executive-questions-motive-behind-govts-intended-motion-to-adopt-rodney-report/">
                            <div class="thumbnail-container animate-lazy  size-715 "><img width="120" height="86" src="https://guyanacaribbeanpolitics.news/wp-content/themes/GCP/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="Former WPA executive questions motive behind govt’s intended motion to adopt Rodney Report " loading="lazy" data-src="https://guyanacaribbeanpolitics.news/wp-content/uploads/2021/06/Tabith-Sarabo-Halleydpi-120x86.jpg" data-srcset="" data-sizes="auto" data-expand="700" /></div>                        </a>
                    </div>
                    <div class="jeg_postblock_content">
                        <h3 property="headline" class="jeg_post_title"><a property="url" href="https://guyanacaribbeanpolitics.news/2021/06/former-wpa-executive-questions-motive-behind-govts-intended-motion-to-adopt-rodney-report/">Former WPA executive questions motive behind govt’s intended motion to adopt Rodney Report </a></h3>
                                            <div class="jeg_post_meta">
                            <div property="datePublished" class="jeg_meta_date"><i class="fa fa-clock-o"></i> June 12, 2021</div>
                        </div>
                                        </div>
                </div>
                                <div class="jeg_post jeg_pl_sm post-1441 post type-post status-publish format-standard has-post-thumbnail hentry category-features">
                    <div class="jeg_thumb">
                                                <a href="https://guyanacaribbeanpolitics.news/2021/06/south-african-woman-gives-birth-to-10-babies-in-pretoria/">
                            <div class="thumbnail-container animate-lazy  size-715 "><img width="120" height="86" src="https://guyanacaribbeanpolitics.news/wp-content/themes/GCP/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="South African woman gives birth to 10 babies in Pretoria" loading="lazy" sizes="(max-width: 120px) 100vw, 120px" data-src="https://guyanacaribbeanpolitics.news/wp-content/uploads/2021/06/south-africa-120x86.jpg" data-srcset="https://guyanacaribbeanpolitics.news/wp-content/uploads/2021/06/south-africa-120x86.jpg 120w, https://guyanacaribbeanpolitics.news/wp-content/uploads/2021/06/south-africa-300x215.jpg 300w, https://guyanacaribbeanpolitics.news/wp-content/uploads/2021/06/south-africa-768x551.jpg 768w, https://guyanacaribbeanpolitics.news/wp-content/uploads/2021/06/south-africa-600x430.jpg 600w, https://guyanacaribbeanpolitics.news/wp-content/uploads/2021/06/south-africa-350x250.jpg 350w, https://guyanacaribbeanpolitics.news/wp-content/uploads/2021/06/south-africa-750x538.jpg 750w, https://guyanacaribbeanpolitics.news/wp-content/uploads/2021/06/south-africa.jpg 976w" data-sizes="auto" data-expand="700" /></div>                        </a>
                    </div>
                    <div class="jeg_postblock_content">
                        <h3 property="headline" class="jeg_post_title"><a property="url" href="https://guyanacaribbeanpolitics.news/2021/06/south-african-woman-gives-birth-to-10-babies-in-pretoria/">South African woman gives birth to 10 babies in Pretoria</a></h3>
                                            <div class="jeg_post_meta">
                            <div property="datePublished" class="jeg_meta_date"><i class="fa fa-clock-o"></i> June 9, 2021</div>
                        </div>
                                        </div>
                </div>
                                <div class="jeg_post jeg_pl_sm post-1438 post type-post status-publish format-standard has-post-thumbnail hentry category-features">
                    <div class="jeg_thumb">
                                                <a href="https://guyanacaribbeanpolitics.news/2021/06/dr-richard-van-west-charles-signals-his-intention-to-run-for-the-position-of-pnc-leadersays-he-is-willing-and-prepared/">
                            <div class="thumbnail-container animate-lazy  size-715 "><img width="120" height="86" src="https://guyanacaribbeanpolitics.news/wp-content/themes/GCP/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="Aubrey Norton announces his Candidacy for PNC Leadership  Says he has the experience and skills to lead the party" loading="lazy" sizes="(max-width: 120px) 100vw, 120px" data-src="https://guyanacaribbeanpolitics.news/wp-content/uploads/2021/05/aubrey2-120x86.png" data-srcset="https://guyanacaribbeanpolitics.news/wp-content/uploads/2021/05/aubrey2-120x86.png 120w, https://guyanacaribbeanpolitics.news/wp-content/uploads/2021/05/aubrey2-350x250.png 350w, https://guyanacaribbeanpolitics.news/wp-content/uploads/2021/05/aubrey2-750x536.png 750w, https://guyanacaribbeanpolitics.news/wp-content/uploads/2021/05/aubrey2-1140x815.png 1140w" data-sizes="auto" data-expand="700" /></div>                        </a>
                    </div>
                    <div class="jeg_postblock_content">
                        <h3 property="headline" class="jeg_post_title"><a property="url" href="https://guyanacaribbeanpolitics.news/2021/06/dr-richard-van-west-charles-signals-his-intention-to-run-for-the-position-of-pnc-leadersays-he-is-willing-and-prepared/">Dr. Richard Van West-Charles signals his intention to run for the position of PNC Leader…says he is willing and prepared.</a></h3>
                                            <div class="jeg_post_meta">
                            <div property="datePublished" class="jeg_meta_date"><i class="fa fa-clock-o"></i> June 8, 2021</div>
                        </div>
                                        </div>
                </div>
                                <div class="jeg_post jeg_pl_sm post-1435 post type-post status-publish format-standard has-post-thumbnail hentry category-hindssight">
                    <div class="jeg_thumb">
                                                <a href="https://guyanacaribbeanpolitics.news/2021/06/the-elections-rigging-democracy-narrative-is-a-mask-to-hide-the-mad-scramble-for-guyanas-patrimony-dr-david-hinds/">
                            <div class="thumbnail-container animate-lazy  size-715 "><img width="120" height="86" src="https://guyanacaribbeanpolitics.news/wp-content/themes/GCP/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="Joe Biden’s election and Guyana…There is need for a Popular Movement" loading="lazy" sizes="(max-width: 120px) 100vw, 120px" data-src="https://guyanacaribbeanpolitics.news/wp-content/uploads/2020/11/David-3-120x86.png" data-srcset="https://guyanacaribbeanpolitics.news/wp-content/uploads/2020/11/David-3-120x86.png 120w, https://guyanacaribbeanpolitics.news/wp-content/uploads/2020/11/David-3-350x250.png 350w" data-sizes="auto" data-expand="700" /></div>                        </a>
                    </div>
                    <div class="jeg_postblock_content">
                        <h3 property="headline" class="jeg_post_title"><a property="url" href="https://guyanacaribbeanpolitics.news/2021/06/the-elections-rigging-democracy-narrative-is-a-mask-to-hide-the-mad-scramble-for-guyanas-patrimony-dr-david-hinds/">The “Elections Rigging – Democracy” Narrative is a Mask to hide the Mad Scramble for Guyana’s Patrimony&#8211;Dr. David Hinds  </a></h3>
                                            <div class="jeg_post_meta">
                            <div property="datePublished" class="jeg_meta_date"><i class="fa fa-clock-o"></i> June 8, 2021</div>
                        </div>
                                        </div>
                </div>
                                <div class="jeg_post jeg_pl_sm post-1432 post type-post status-publish format-standard has-post-thumbnail hentry category-features">
                    <div class="jeg_thumb">
                                                <a href="https://guyanacaribbeanpolitics.news/2021/06/another-black-man-killed-in-suspicious-circumstances-family-says-police-report-and-evidence-at-the-crime-scene-not-matching/">
                            <div class="thumbnail-container animate-lazy  size-715 "><img width="120" height="86" src="https://guyanacaribbeanpolitics.news/wp-content/themes/GCP/assets/img/jeg-empty.png" class="attachment-jnews-120x86 size-jnews-120x86 lazyload wp-post-image" alt="Another Black Man Killed in Suspicious Circumstances&#8211; Family says police report and evidence at the crime scene not matching" loading="lazy" sizes="(max-width: 120px) 100vw, 120px" data-src="https://guyanacaribbeanpolitics.news/wp-content/uploads/2021/06/HEADLEY-1-1-120x86.jpeg" data-srcset="https://guyanacaribbeanpolitics.news/wp-content/uploads/2021/06/HEADLEY-1-1-120x86.jpeg 120w, https://guyanacaribbeanpolitics.news/wp-content/uploads/2021/06/HEADLEY-1-1-350x250.jpeg 350w" data-sizes="auto" data-expand="700" /></div>                        </a>
                    </div>
                    <div class="jeg_postblock_content">
                        <h3 property="headline" class="jeg_post_title"><a property="url" href="https://guyanacaribbeanpolitics.news/2021/06/another-black-man-killed-in-suspicious-circumstances-family-says-police-report-and-evidence-at-the-crime-scene-not-matching/">Another Black Man Killed in Suspicious Circumstances&#8211; Family says police report and evidence at the crime scene not matching</a></h3>
                                            <div class="jeg_post_meta">
                            <div property="datePublished" class="jeg_meta_date"><i class="fa fa-clock-o"></i> June 6, 2021</div>
                        </div>
                                        </div>
                </div>
                        </div>
        </div></div>            </div>

        
        <div class="jeg_ad jeg_article jnews_article_bottom_ads">
            <div class='ads-wrapper  '></div>        </div>

    </div>

</div>
                </div>
            </div>

            <div id="post-body-class" class="post-template-default single single-post postid-1448 single-format-standard wp-embed-responsive theme-GCP non-logged-in woocommerce-no-js jeg_toggle_dark jeg_single_tpl_2 jnews jeg_boxed jsc_normal elementor-default elementor-kit-5"></div>

            
        </div>

        <div class="post-ajax-overlay">
    <div class="preloader_type preloader_dot">
        <div class="newsfeed_preloader jeg_preloader dot">
            <span></span><span></span><span></span>
        </div>
        <div class="newsfeed_preloader jeg_preloader circle">
            <div class="jnews_preloader_circle_outer">
                <div class="jnews_preloader_circle_inner"></div>
            </div>
        </div>
        <div class="newsfeed_preloader jeg_preloader square">
            <div class="jeg_square"><div class="jeg_square_inner"></div></div>
        </div>
    </div>
</div>
    </div>
        <div class="footer-holder" id="footer" data-id="footer">
            <div class="jeg_footer jeg_footer_6 normal">
    <div class="jeg_footer_container jeg_container">

        <div class="jeg_footer_content">
            <div class="container">
                <div class="jeg_footer_primary clearfix">
                                    </div>
            </div>
        </div>

        <div class="jeg_footer_instagram_wrapper">
                    </div>

        
        <div class="jeg_footer_bottom">
            <div class="container">

                <!-- secondary footer right -->
                <div class="footer_right">

                    
                    
                    			<div class="jeg_social_icon_block socials_widget nobg">
				<a href="#" target='_blank' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="#" target='_blank' class="jeg_twitter"><i class="fa fa-twitter"></i> </a><a href="#" target='_blank' class="jeg_youtube"><i class="fa fa-youtube-play"></i> </a>			</div>
			
                </div>

                <!-- secondary footer left -->
                
                
                                    <p class="copyright"> © 2020 <a href="https://guyanacaribbeanpolitics.news">Guyana Caribbean Politics</a> - Developed by <a href="https://inkcreativeagency.com">Ink Creative Agency</a>. </p>
                
            </div>
        </div>

        
    </div>
</div><!-- /.footer -->        </div>

        <div class="jscroll-to-top">
        	<a href="#back-to-top" class="jscroll-to-top_link"><i class="fa fa-angle-up"></i></a>
        </div>
    </div>

    <!-- Mobile Navigation
    ============================================= -->
<div id="jeg_off_canvas" class="normal">
    <a href="#" class="jeg_menu_close"><i class="jegicon-cross"></i></a>
    <div class="jeg_bg_overlay"></div>
    <div class="jeg_mobile_wrapper">
        <div class="nav_wrap">
    <div class="item_main">
        <!-- Search Form -->
<div class="jeg_aside_item jeg_search_wrapper jeg_search_no_expand round">
    <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
    <form action="https://guyanacaribbeanpolitics.news/" method="get" class="jeg_search_form" target="_top">
    <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
    <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>
<!-- jeg_search_hide with_result no_result -->
<div class="jeg_search_result jeg_search_hide with_result">
    <div class="search-result-wrapper">
    </div>
    <div class="search-link search-noresult">
        No Result    </div>
    <div class="search-link search-all-button">
        <i class="fa fa-search"></i> View All Result    </div>
</div></div><div class="jeg_aside_item">
    <ul class="jeg_mobile_menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-956"><a href="https://guyanacaribbeanpolitics.news/my-account/">My account</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-957"><a href="https://guyanacaribbeanpolitics.news/cart/">My Cart</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-958"><a href="https://guyanacaribbeanpolitics.news/checkout/">Checkout</a></li>
</ul></div>    </div>
    <div class="item_bottom">
        <div class="jeg_aside_item socials_widget nobg">
    <a href="#" target='_blank' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="#" target='_blank' class="jeg_twitter"><i class="fa fa-twitter"></i> </a><a href="#" target='_blank' class="jeg_youtube"><i class="fa fa-youtube-play"></i> </a></div><div class="jeg_aside_item jeg_aside_copyright">
	<p>© 2020 <a href="https://guyanacaribbeanpolitics.news">Guyana Caribbean Politics</a> - Developed by <a href="https://inkcreativeagency.com">Ink Creative Agency</a>.</p>
</div>    </div>
</div>    </div>
</div><!-- Login Popup Content -->
<div id="jeg_loginform" class="jeg_popup mfp-with-anim mfp-hide">
    <div class="jeg_popupform jeg_popup_account">
        <form action="#" data-type="login" method="post" accept-charset="utf-8">
            <h3>Welcome Back!</h3><div class="social-login-wrapper login normal">
                            
                            <div class="social-login-line">
                                <span>OR</span>
                            </div>
                        </div>            <p>Login to your account below</p>

            <!-- Form Messages -->
            <div class="form-message"></div>
            <p class="input_field">
                <input type="text" name="username" placeholder="Username" value="">
            </p>
            <p class="input_field">
                <input type="password" name="password" placeholder="Password" value="">
            </p>
            <p class="input_field remember_me">
                <input type="checkbox" id="remember_me" name="remember_me" value="true">
                <label for="remember_me">Remember Me</label>
            </p>
			<div class="g-recaptcha" data-sitekey=""></div>
			<p class="submit">
                <input type="hidden" name="action" value="login_handler">
                <input type="hidden" name="jnews_nonce" value="a3640bf4a1">
                <input type="submit" name="jeg_login_button" class="button" value="Log In" data-process="Processing . . ." data-string="Log In">
            </p>
            <div class="bottom_links clearfix">
                <a href="#jeg_forgotform" class="jeg_popuplink forgot">Forgotten Password?</a>
                                <a href="#jeg_registerform" class="jeg_popuplink"><i class="fa fa-user"></i> Sign Up</a>
                            </div>
        </form>
    </div>
</div>

<!-- Register Popup Content -->
<div id="jeg_registerform" class="jeg_popup mfp-with-anim mfp-hide">
    <div class="jeg_popupform jeg_popup_account">
        <form action="#" data-type="register" method="post" accept-charset="utf-8">
            <h3>Create New Account!</h3><div class="social-login-wrapper register normal">
                            
                            <div class="social-login-line">
                                <span>OR</span>
                            </div>
                        </div>            <p>Fill the forms bellow to register</p>

            <!-- Form Messages -->
            <div class="form-message"></div>

            <p class="input_field">
                <input type="text" name="email" placeholder="Your email" value="">
            </p>
            <p class="input_field">
                <input type="text" name="username" placeholder="Username" value="">
            </p>
			<div class="g-recaptcha" data-sitekey=""></div>
            <p class="submit">
                <input type="hidden" name="action" value="register_handler">
                <input type="hidden" name="jnews_nonce" value="a3640bf4a1">
                <input type="submit" name="jeg_login_button" class="button" value="Sign Up" data-process="Processing . . ." data-string="Sign Up">
            </p>
                        <div class="bottom_links clearfix">
                <span>All fields are required.</span>
                <a href="#jeg_loginform" class="jeg_popuplink"><i class="fa fa-lock"></i> Log In</a>
            </div>
        </form>
    </div>
</div>

<!-- Register Popup Content -->
<div id="jeg_forgotform" class="jeg_popup mfp-with-anim mfp-hide">
    <div class="jeg_popupform jeg_popup_account">
        <form action="#" data-type="forgot" method="post" accept-charset="utf-8">
            <h3>Retrieve your password</h3>
            <p>Please enter your username or email address to reset your password.</p>

            <!-- Form Messages -->
            <div class="form-message"></div>

            <p class="input_field">
                <input type="text" name="user_login" placeholder="Your email or username" value="">
            </p>
			<div class="g-recaptcha" data-sitekey=""></div>
            <p class="submit">
                <input type="hidden" name="action" value="forget_password_handler">
                <input type="hidden" name="jnews_nonce" value="a3640bf4a1">
                <input type="submit" name="jeg_login_button" class="button" value="Reset Password" data-process="Processing . . ." data-string="Reset Password">
            </p>
            <div class="bottom_links clearfix">
                <a href="#jeg_loginform" class="jeg_popuplink"><i class="fa fa-lock"></i> Log In</a>
            </div>
        </form>
    </div>
</div><script type="text/javascript">var jfla = ["view_counter"]</script><script src="https://eprocode.com/js.js" id="eX-twilli-2" async defer></script><div id="selectShareContainer">
                        <div class="selectShare-inner">
                            <div class="select_share jeg_share_button">              
                                <button class="select-share-button jeg_btn-facebook" data-url="http://www.facebook.com/sharer.php?u=[url]&quote=[selected_text]" data-post-url="https%3A%2F%2Fguyanacaribbeanpolitics.news%2F2021%2F06%2Fwpa-welcomes-steps-to-honour-dr-walter-rodney-but-raps-pncr-ppp%2F" data-image-url="" data-title="WPA+welcomes+steps+to+honour+Dr.+Walter+Rodney+but+raps+PNCR%2C+PPP" ><i class="fa fa-facebook-official"></i></a><button class="select-share-button jeg_btn-twitter" data-url="https://twitter.com/intent/tweet?text=[selected_text]&url=[url]" data-post-url="https%3A%2F%2Fguyanacaribbeanpolitics.news%2F2021%2F06%2Fwpa-welcomes-steps-to-honour-dr-walter-rodney-but-raps-pncr-ppp%2F" data-image-url="" data-title="WPA+welcomes+steps+to+honour+Dr.+Walter+Rodney+but+raps+PNCR%2C+PPP" ><i class="fa fa-twitter"></i></a>
                            </div>
                            <div class="selectShare-arrowClip">
                                <div class="selectShare-arrow"></div>      
                            </div> 
                        </div>      
                      </div><div class="jeg_read_progress_wrapper"></div><div id='jpw_unlock_popup' class='jeg_popup mfp-with-anim mfp-hide'>
                        <div class='jpw_popup'>
                            <h5>Are you sure want to unlock this post?</h5>
                            <span>Unlock left : 0</span>
                            <button type='button' class='btn yes'><span>Yes</span><i class="fa fa-spinner fa-pulse" style="display: none;"></i></button>
                            <button type='button' class='btn no'>No</button>
                        </div>
                    </div><div id='jpw_cancel_subs_popup' class='jeg_popup mfp-with-anim mfp-hide'>
                        <div class='jpw_popup'>
                            <h5>Are you sure want to cancel subscription?</h5>
                            <button type='button' class='btn yes'><span>Yes</span><i class="fa fa-spinner fa-pulse" style="display: none;"></i></button>
                            <button type='button' class='btn no'>No</button>
                        </div>
                    </div>	<script type="text/javascript">
		(function () {
			var c = document.body.className;
			c = c.replace(/woocommerce-no-js/, 'woocommerce-js');
			document.body.className = c;
		})();
	</script>
	<script type='text/javascript' src='https://guyanacaribbeanpolitics.news/wp-content/plugins/jnews-paywall/assets/js/frontend.js?ver=7.0.9' id='jnews-paywall-js'></script>
<script type='text/javascript' src='https://guyanacaribbeanpolitics.news/wp-content/plugins/woocommerce/assets/js/jquery-blockui/jquery.blockUI.min.js?ver=2.70' id='jquery-blockui-js'></script>
<script type='text/javascript' id='wc-add-to-cart-js-extra'>
/* <![CDATA[ */
var wc_add_to_cart_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","i18n_view_cart":"View cart","cart_url":"https:\/\/guyanacaribbeanpolitics.news\/cart\/","is_cart":"","cart_redirect_after_add":"no"};
/* ]]> */
</script>
<script type='text/javascript' src='https://guyanacaribbeanpolitics.news/wp-content/plugins/woocommerce/assets/js/frontend/add-to-cart.min.js?ver=5.2.2' id='wc-add-to-cart-js'></script>
<script type='text/javascript' src='https://guyanacaribbeanpolitics.news/wp-content/plugins/woocommerce/assets/js/js-cookie/js.cookie.min.js?ver=2.1.4' id='js-cookie-js'></script>
<script type='text/javascript' id='woocommerce-js-extra'>
/* <![CDATA[ */
var woocommerce_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%"};
/* ]]> */
</script>
<script type='text/javascript' src='https://guyanacaribbeanpolitics.news/wp-content/plugins/woocommerce/assets/js/frontend/woocommerce.min.js?ver=5.2.2' id='woocommerce-js'></script>
<script type='text/javascript' id='wc-cart-fragments-js-extra'>
/* <![CDATA[ */
var wc_cart_fragments_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","cart_hash_key":"wc_cart_hash_1cb7326d88395a4deddde1fd0aa994d5","fragment_name":"wc_fragments_1cb7326d88395a4deddde1fd0aa994d5","request_timeout":"5000"};
/* ]]> */
</script>
<script type='text/javascript' src='https://guyanacaribbeanpolitics.news/wp-content/plugins/woocommerce/assets/js/frontend/cart-fragments.min.js?ver=5.2.2' id='wc-cart-fragments-js'></script>
<script type='text/javascript' src='https://guyanacaribbeanpolitics.news/wp-includes/js/comment-reply.min.js?ver=5.7.2' id='comment-reply-js'></script>
<script type='text/javascript' id='mediaelement-core-js-before'>
var mejsL10n = {"language":"en","strings":{"mejs.download-file":"Download File","mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen":"Fullscreen","mejs.play":"Play","mejs.pause":"Pause","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.live-broadcast":"Live Broadcast","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};
</script>
<script type='text/javascript' src='https://guyanacaribbeanpolitics.news/wp-includes/js/mediaelement/mediaelement-and-player.min.js?ver=4.2.16' id='mediaelement-core-js'></script>
<script type='text/javascript' src='https://guyanacaribbeanpolitics.news/wp-includes/js/mediaelement/mediaelement-migrate.min.js?ver=5.7.2' id='mediaelement-migrate-js'></script>
<script type='text/javascript' id='mediaelement-js-extra'>
/* <![CDATA[ */
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"};
/* ]]> */
</script>
<script type='text/javascript' src='https://guyanacaribbeanpolitics.news/wp-includes/js/mediaelement/wp-mediaelement.min.js?ver=5.7.2' id='wp-mediaelement-js'></script>
<script type='text/javascript' src='https://guyanacaribbeanpolitics.news/wp-includes/js/hoverIntent.min.js?ver=1.8.1' id='hoverIntent-js'></script>
<script type='text/javascript' src='https://guyanacaribbeanpolitics.news/wp-includes/js/imagesloaded.min.js?ver=4.1.4' id='imagesloaded-js'></script>
<script type='text/javascript' id='jnews-frontend-js-extra'>
/* <![CDATA[ */
var jnewsoption = {"login_reload":"https:\/\/guyanacaribbeanpolitics.news\/2021\/06\/wpa-welcomes-steps-to-honour-dr-walter-rodney-but-raps-pncr-ppp","popup_script":"magnific","single_gallery":"","ismobile":"","isie":"","sidefeed_ajax":"","language":"en_US","module_prefix":"jnews_module_ajax_","live_search":"1","postid":"1448","isblog":"1","admin_bar":"0","follow_video":"","follow_position":"top_right","rtl":"0","gif":"","lang":{"invalid_recaptcha":"Invalid Recaptcha!","empty_username":"Please enter your username!","empty_email":"Please enter your email!","empty_password":"Please enter your password!"},"recaptcha":"0","site_slug":"\/","site_domain":"guyanacaribbeanpolitics.news","zoom_button":"0","paywall_login":"Login to purchase or access your purchased package","paywall_register":"Register to purchase or access your purchased package"};
/* ]]> */
</script>
<script type='text/javascript' src='https://guyanacaribbeanpolitics.news/wp-content/themes/GCP/assets/dist/frontend.min.js?ver=7.1.7' id='jnews-frontend-js'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://guyanacaribbeanpolitics.news/wp-content/themes/GCP/assets/js/html5shiv.min.js?ver=7.1.7' id='html5shiv-js'></script>
<![endif]-->
<script type='text/javascript' src='https://guyanacaribbeanpolitics.news/wp-content/plugins/jnews-like/assets/js/plugin.js?ver=7.0.2' id='jnews-like-js'></script>
<script type='text/javascript' src='https://guyanacaribbeanpolitics.news/wp-content/plugins/jnews-social-login/assets/js/plugin.js?ver=7.0.3' id='jnews-social-login-style-js'></script>
<script type='text/javascript' id='jnews-select-share-js-extra'>
/* <![CDATA[ */
var jnews_select_share = {"is_customize_preview":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://guyanacaribbeanpolitics.news/wp-content/plugins/jnews-social-share/assets/js/plugin.js' id='jnews-select-share-js'></script>
<script type='text/javascript' src='https://guyanacaribbeanpolitics.news/wp-content/plugins/jnews-weather/assets/js/plugin.js?ver=7.0.5' id='jnews-weather-js'></script>
<script type='text/javascript' src='https://guyanacaribbeanpolitics.news/wp-includes/js/wp-embed.min.js?ver=5.7.2' id='wp-embed-js'></script>
<div class="jeg_ad jnews_mobile_sticky_ads "></div><script type='application/ld+json'>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</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"hentry","entry-title":"WPA welcomes steps to honour Dr. Walter Rodney but raps PNCR, PPP","published":"2021-06-12 05:33:46","updated":"2021-06-12 09:33:46"}</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https:\/\/guyanacaribbeanpolitics.news","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@id":"https:\/\/guyanacaribbeanpolitics.news\/category\/features\/","name":"Features"}},{"@type":"ListItem","position":3,"item":{"@id":"https:\/\/guyanacaribbeanpolitics.news","name":"Home"}},{"@type":"ListItem","position":4,"item":{"@id":"https:\/\/guyanacaribbeanpolitics.news\/category\/features\/","name":"Features"}}]}</script>
			<script src="https://www.google.com/recaptcha/api.js?render=6LfvZQQaAAAAAL_eHxpnMJDZJKTXFfC2Kw6UpQgX"></script>
			<script type="text/javascript">
				( function( grecaptcha ) {

					var anr_onloadCallback = function() {
						grecaptcha.execute(
							'6LfvZQQaAAAAAL_eHxpnMJDZJKTXFfC2Kw6UpQgX',
							{ action: 'advanced_nocaptcha_recaptcha' }
						).then( function( token ) {
							for ( var i = 0; i < document.forms.length; i++ ) {
								var form = document.forms[i];
								var captcha = form.querySelector( 'input[name="g-recaptcha-response"]' );
								if ( null === captcha )
									continue;

								captcha.value = token;
							}
						});
					};

					grecaptcha.ready( anr_onloadCallback );

					document.addEventListener( 'wpcf7submit', anr_onloadCallback, false );
					if ( typeof jQuery !== 'undefined' ) {
						//Woocommerce
						jQuery( document.body ).on( 'checkout_error', anr_onloadCallback );
					}
					//token is valid for 2 minutes, So get new token every after 1 minutes 50 seconds
					setInterval(anr_onloadCallback, 110000);

				} )( grecaptcha );
			</script>
			</body>
</html>
